Page MenuHomeDiscord Bugs

Pasting from the right-click context menu in modals pastes into the message bar instead
Closed, ResolvedPublic

Details

Asana Task ID
1192252696328241
Bug Report ID
602
Reporter
wakfi#6999
Reproduction Steps
  • Copy some text
  • Open emoji picker
  • Right click in search bar
  • Click "Paste"
Expected Behavior

The content of the clipboard is pasted into the search bar of the modal

Current Behavior

The emoji picker closes and the content of clipboard is pasted into the message text box

Client Details

Canary 63958 (1c8ea0a), Host 0.0.266

System Details

Dell Precision 5520: Windows 10 Pro 64-Bit (10.0.18363)

Event Timeline

bugbot created this task.Jul 22 2020, 6:26 PM
bugbot created this object in space S2 Public.
bugbot created this object with visibility "Public (No Login Required)".

Can reproduce.
Canary 63877 (f8f6d51) Host 0.0.266 Windows 10 64-Bit (10.0.17134 [CR]

Chay#3670

Can reproduce.
Canary 63958 (1c8ea0a), Windows 10 64-Bit (10.0.18362)

Leah#4172

Can reproduce.
Canary 63843 (6d9d4a7), Windows 10 Pro 64 Bit

Renan#5000

Can reproduce.
Extensions: Also occurs in search bar for adding user to group DM. With formatting preview on, also occurs in all text fields in user settings, editing server name and role name, hex code for role color, search bar in bans & members, editing channel name and description, editing folder name, and search bar to invite friends to server. Nothing is pasted regardless of preview in channel creation name field or server discovery search bar. Folder color hex code, server creation name field, and category creation name field can be pasted into properly

wakfi#6999

Can reproduce.
Canary 63965 (f018f62), Windows 10 64-Bit (10.0.19041)

bsoyka#0001

Can reproduce.
Can reproduce.
Canary 64036 (be2b10c), Windows 10 64-Bit (10.0.19041)
Canary 64089 (0f431c6), Linux 64-Bit (4.19.0-9-Amd64)

SpikeyRobot#0001

Can't reproduce.
works fine for me, might be windows-sepcific Safari Version 13.1.1 (13609.2.9.1.3), MacOs High Sierra Version 10.13.6; discord.com, Release Channel: stable, Build Number: 63923, Version Hash: b2b83f2161bea771aac2803602769aa858d05839

conqr#0001

Can reproduce.
MacBook Pro (Mid 2015): macOS Catalina 10.15.6; Canary 65945 \~ Host 0.0.256

Jiralite#1207

john assigned this task to faulty.Sep 3 2020, 3:11 PM
john triaged this task as P2 priority.
john added a project: Unknown Object (Project).
asanabot set Asana Task ID to 1192252696328241.Sep 3 2020, 3:11 PM

An Asana task has been opened up for this at https://app.asana.com/0/0/1192252696328241

john moved this task from Inbox to Assigned on the Discord Desktop board.Sep 3 2020, 3:11 PM
asanabot closed this task as Resolved.Sep 3 2020, 4:00 PM

Can reproduce.
Win10, Build 19041.508, Discord Canary 69647

Just a Regular Spooky Box#5472